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emutel
TM

|Virtuoso The emutel
TM

|Virtuoso simulates a Central Office switch.  Depending on 

which cards are inserted the switch can emulate V5.1, V5.2, basic rate ISDN, 

primary rate ISDN, or analogue telephone networks. 

 

A call on any bearer channel on any interface can be connected to any other 

bearer channel on any other interface. 

 

The setup and configuration of emutel
TM

|Virtuoso is achieved via a Windows 

application program.  A protocol analyser is available as a software option. 

 

The manual This manual outlines how the emutel
TM

|Virtuoso should be set up and how 

the network and terminal equipment are connected. 
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ISDN Connections emutel
TM

|Virtuoso can simulate, basic rate ISDN on either an S0 or U 

interface, analogue, primary rate ISDN on either E1 (S2m) or T1, V5.1 and 

V5.2 on up to 8 E1 (S2m) links. 

 

Terminal Port A V.24 port is provided allowing the connection of a PC for configuration 

and analysis of the unit. 

 

Ethernet Port An IEEE 802.3 Ethernet port is provided for connection to a local area 

network. 

 

LEDs indicate (1) network present, (2) network activity. 

 

Power  emutel
TM

|Virtuoso is available in mains powered and dc powered versions.  

The mains version accepts a voltage of 110-240V AC (50-60Hz).  The dc 

version accepts a voltage of –36V to –72V DC 

 

V5 Connections emutel
TM

|Virtuoso can support up to 8 V5 interfaces running a combination 

of V5.1 and V5.2. 

 

The number and type of V5 interfaces available to the user will be determined 

at time of purchase.  

  

Unpack emutel
TM

|Virtuoso First unpack emutel
TM

|Virtuoso and check for signs of damage in transit.  If 

the unit or packaging is damaged this should be reported immediately to arca 

technologies. 

  

Take an Inventory Take an inventory of the parts supplied.  Check that the items ordered were 

actually received.  The list below should be of help in identifying each part. 

  

 ♦ emutel
TM

|Virtuoso V5 Local Exchange Simulator 

♦ Cables for ISDN - RJ45-RJ45 

♦ Mains Cable 

♦ Terminal Cable DB9-DB9 (1 of) 

♦ This Manual 
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Connect to a PC or terminal Plug the terminal cable into the terminal connector on the controller card at 

the front of the unit and connect to a PC.  

 

(emutel
TM

|Virtuoso default terminal settings are ANSI terminal compatible, 

19200-baud, 8 data bits, no parity, 2 stop bits). 

  

Connect power Plug the power cable into the rear of the unit and switch on.  

(emutel
TM

|Virtuoso will work on 110V or 240V mains supply without 

adjustment). 

  

Connect terminal equipment E1 links can be connected to the emutel
TM

|Virtuoso using the RJ-45 cables 

provided. For V5.2, the Primary and Secondary links port are defined in the 

configuration file.   
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Introduction emutel
TM

|Virtuoso consists of a chassis, mains or dc power supply, controller 

card and up to 2 line cards. 

 

The controller card must be fitted in the first slot.  

 

There are no user serviceable parts inside emutel
TM

|Virtuoso.  Removal of 

the case by unauthorised staff will result in a void of warranty. 

 

 

 

 Figure 1 emutel
TM

|Virtuoso front and rear panels 

  

Chassis The chassis consists of a metal case and a back plane to accept the controller 

card, line cards and power supply. 

  



QUICK REFERENCE GUIDE 

Chapter 3                  6 

Mains Power supply The mains power supply has a universal input suitable for 110V-240Vac/50-

60Hz.  Connection to any other source may result in the unit failing to comply 

with safety requirements.  

 

Power should be supplied via an IEC mains lead (supplied). 

 

The power supply must have a protective ground (earth).  If not the 

mains filter will force the metal case to a voltage equal to half the mains 

supply voltage. 

  

DC power supply The dc power supply has 2 input connectors.  Both accept a voltage of –36V 

to –72V.  Power can be connected to either or both input connectors. 

 

NB the 0V connections on both connectors are common and are 

connected to the case.  The 0V connection should be connected to earth. 

 

 

 

 

  

 Figure 2 emutel
TM

|Virtuoso controller card 

 

Controller card The controller card can feature 2 primary rate ports, 2 PC Card 

slots, modem, LAN port, terminal port and LEDs.   

 

The terminal port is a V.24 compatible control port to which a PC 

running the application provided could be connected. 

  

 The LAN port is an IEEE 802.3 compatible Ethernet port.  It 

allows emutel
TM

|Virtuoso to be controlled remotely via Telnet.   

 

The Line port, which allows modem access, permits connection to 

a real line. This feature will be implemented at a later date. 
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 Port 1 and port 2 are the pin-outs of the terminal.  Ethernet, modem and PRI 

ports are given in an Appendix 2.  

 

LEDs indicate power and alarm. 

 

For each primary rate port the P LED is on when both physical link layer and 

data link layer are active.  It flashes when only the physical link is active.  

The B LED is on when any B channel is in use. 

 

For the Ethernet port the P LED indicates network present and the B LED 

indicates network activity. 

 

For the modem port the P LED is on for off-hook and flashing for ringing.  

The B LED indicates data transfer. 

 

 

 Figure 3 emutel
TM

|Virtuoso U card and S card 
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U and S cards The U and S cards feature 8 Basic Rate Ports and LEDs. 

 

Ports 1-8 are BRI 1-8 if fitted in the first line card slot or BRI 9-16 if fitted in 

the second line card slot. 

 

Pin-outs of the BRI interfaces are given in appendix 2. 

 

LEDs indicate power and alarm. 

 

For each port the P LED is on when both physical link layer and data link 

layer are active.  It flashes when only the physical link is active.  The B LED 

is on when any B channel is in use. 

  

Restoring default settings When the unit is first switched on the terminal port will default to 19200-

baud, no parity, 8 data bits and 2 stop bits and will search for a <ctrl-c> being 

transmitted to emutel
TM

|Virtuoso.  If this occurs emutel
TM

|Virtuoso will 

restore the factory defaults otherwise it will use the stored settings. 

 

If a setting has been changed and emutel
TM

|Virtuoso ceases to operate, 

powering up emutel
TM

|Virtuoso, while holding down <ctrl-c> for the first 20 

seconds, will restore a working configuration to emutel
TM

|Virtuoso. 

 

 

 

 

 Figure 4 emutel
TM

|Virtuoso V5 card 

  



QUICK REFERENCE GUIDE 

Chapter 3                  9 

V5CARD The V5card features 8 E1 Ports and LEDs. 

 

Pin-outs of the PRI interfaces are given in Appendix 2. 

 

LEDs indicate power and alarm. The alarm LED will be on if there is an error 

with the V5 card. 

 

For each port the P LED is on when the physical link layer is active.  The D 

LED is on when any of the data link layers are active. 



SOFTWARE INSTALLATION 

Chapter 4                  10 

 

Software installation The emutel
TM

|Virtuoso is controlled using the emutel
TM

|Virtuoso Windows 

application.  This application is capable of running on a PC with windows 

95/98/2000 and NT operating systems. 

  

Installation of software The emutel
TM

|Virtuoso Windows application and V5Analyser can be 

installed using the CD provided.  If auto-run is not enabled on the CD, 

browse to the V5Rack_V1.21.exe in the Install_V1.21 folder. Double-click 

on the file to start the installation and follow the on screen instructions.  Once 

completed the software will be installed on the local drive c:\program 

files\arca technologies\emutel Virtuoso. 

  

emutel
TM

|Virtuoso folder contents This folder contains. 

 

- emutel
TM

|Virtuoso Windows Application (V5Rack) 

This program is used to control the configuration and display the current state 

of each port of the emutel
TM

|Virtuoso. 

 

- V5Analyser 

The V5Analyser displays full decoding of the V5 protocol and ISDN protocol 

as well as providing statistical analysis. 

 

- V5Rack.HLP 

The Help file for the V5Rack program. 

 

- V5Rack.cnt 

The contents section of the Help file for the V5Rack program. 

 

CFG Folder 

This folder contains two text file templates for configuration purposes. 

 

- V51config.V5 

The V51CONFIG file is a template for the text file used to configure the 

emutel
TM

|Virtuoso to the users V5.1 interface requirements. 

 

- V52config.V5 

The V52CONFIG file is a template for the text file used to configure the 

emutel
TM

|Virtuoso to the users V5.2 interface requirements. 
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Introduction to the windows application Before using the emutel
TM

|Virtuoso, the unit must be correctly connected 

and the configuration must match that of the corresponding Access Network. 

This is achieved using the emutel Windows application V5Rack, supplied 

with the unit. The unit connection will be considered first. 

  

 The emutel
TM

|Virtuoso can be connected in two ways, using the RS-232 port 

or a LAN connection. Both are described below. 

 

1. RS-232 connection 

 

To connect the V5Rack to the emutel
TM

|Virtuoso use the RS-232 cable 

provided.  Connect the RS-232 cable to the nine-way D-type connector 

situated at the front of the Controller card. 

 

From the V5Rack menu select Connection -> Configuration.  After a short 

time lag, the V5Rack application will display the current configuration of the 

emutel
TM

|Virtuoso. Set the RS-232 port settings as shown below. 
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 To use the RS-232 as the default connection, tick the “Set as Default 

Connection” checkbox. 

  

 2. Ethernet connection 

 

To connect the V5Rack to the emutel
TM

|Virtuoso use a RJ-45 cable.  

Connect the cable to the LAN connector situated at the front of the Controller 

card.  From the V5Rack menu select Connection -> Configuration and select 

the TCP/IP tab. 

  

  

 The Ethernet default settings are shown in the configuration window above.  

Before selecting OK,  tick the “Set as Default Connection”. 
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Viewing V5 systems Once the connection to the unit has been established using the Windows 

application, the available V5 systems are displayed as small icons. Clicking 

on a specific system icon displays a detailed visual representation of that 

system. For more detailed information refer to Chapter 7 and the online Help 

file in V5Rack. 

  

Changing the configuration A new text file needs to be generated that matches any new configuration 

requirements.  Once the text file has been generated, this file can be uploaded 

to the unit.  Select File -> Upload V5Config.  Choose the required file to be 

uploaded to the emutel
TM

|Virtuoso.  The windows software will ask the unit 

to reset the system so that the changes can take place. If the file has been 

uploaded correctly the new systems and ports displayed on the screen will 

match those in the text file. 

 

A more detailed description of the V5Rack functions is given in Chapter 7. 

  

Connecting the V5Analyser Using the V5Rack menu select Analyser -> analyser on. This will enable 

the emutel
TM

|Virtuoso to transmit analyser messages. 

 

From the arca technologies directory, launch the V5Analyser.  When the 

main window is displayed, connect the V5Analyser by clicking on the icon 

shown below. 

 

A successful connection will display the following window. 
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 Analyser messages will now be displayed.  Further information on the 

analyser menus can be found using the online help in V5Analyser. 

 

Summary The instructions given so far, will ensure that the emutel
TM

|Virtuoso Local 

Exchange Simulator is set up correctly. A more detailed explanation of the 

operation of the V5Rack and V5Anayser are detailed in Chapters 7 and 

Chapter 9.  Further information is also available in the online help in these 

programs. 

Finally, the telephone numbers for the emutel
TM

|Virtuoso are detailed in 

Appendix 1.  

  

 



FAULT FINDING 

Chapter 6                  15 

Introduction to fault finding Due to the nature of the V5 protocol care must be taken when changing the 

configuration of the unit.  Here are some examples of operator error that may 

help eliminate initial problems. 

  

Unable to connect to the emutel
TM

|Virtuoso 

using the V5Rack 

You should first ensure that the port settings are correct.  If the problem 

persists further then: 

 

♦ Using a Dumb terminal, such as HyperTerminal set the Baud rate to 

19200. 

♦ Power cycle the unit 

♦ On power up press CTRL + C 

♦ Reset should continuously be displayed on the screen 

♦ Release the Keys until the arca technologies copyright screen appears 

♦ Press Enter and then Enter into the Hardware set-up menu 

♦ Using the Space bar change the Baud Rate of the unit to 115200 and 

press ESC 

♦ Closed down the Dumb terminal and try to connect to the unit again 

  

Configuration errors If the expected change in configuration has not occurred after uploading a 

new configuration file to the emutel
TM

|Virtuoso, power cycle the unit and 

reconnect to the emutel
TM

|Virtuoso using the V5Rack application.  If the 

configuration changes have not taken place then the problem may be due to: 

 

Incorrect configuration for version.  The user may be trying to upload a 

configuration that does not match the allowed configuration of the unit.  

Check with your supplier or arca technologies to detail the configuration 

limitations set at time of purchase. 

 

Incorrect configuration.  There may be errors in the text file used to 

generate the configuration file.  This could be due to missing, incorrect or 

invalid configuration text.  Check the text file for mistakes such as duplicated 

layer3 addresses on the same system. 
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V5Rack application introduction The following information provides a brief overview of the V5Rack 

application menu options. For more comprehensive information, please refer 

to the online Help. This is accessible under the Help->Help Topics menu. 

 

File -> SaveV5 Config This enables the user to save the units current configuration to file. 

 

File -> Upload V5Config Opens a configuration file and uploads it to the emutel
TM

|Virtuoso.  

Configuration files are of type *.V5 

 

Connection -> Configuration Enables the user to select and configure the connection type ( RS-232 or 

Ethernet ). The user can also set properties of the capture file for the emutel 

Rack System Messages  

 

Connection -> Connect This function enables the user to connect the emutel V5Rack software to the 

emutel
TM

|Virtuoso using the default connection path. 

 

Connection -> Disconnect This function enables the user to disconnect the emutel V5Rack software 

from the emutel
TM

|Virtuoso. 

 

System -> Reset System Enables the user to force the system to reset. This has the same function as 

power cycling the unit. 

 

System-> Request Configuration This function enables the user to request the current configuration of the unit 

from the emutel
TM

|Virtuoso. 

 

System -> Magic Number Enables a qualified technician to send a new magic number to the unit 

providing enhanced functionality. 

 

Analyser -> Analyser On/Off Enables the emutel
TM

|Virtuoso to send analyser messages to the V5 protocol 

analyser. 

 

View -> System Messages Enables the user to view all the messages and decoding that are being passed 

to and from the emutel Windows application to emutel
TM

|Virtuoso. 

 

View -> V5 Unit Bar The V5 Unit Bar enables the user to see the current V5 settings that are 

enabled on the unit such as number of links and type of interface. 
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  The Connection Bar displays the connection status of the unit and remote 

analyser. 

  

View -> Status Bar This toolbar displays help descriptions of menu items. 

Help->Help Topics Comprehensive online Help guide. 

Help->About V5 Copyright information. 
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Using the V5Rack graphical user interface Once the V5Rack application is connected to the emutel
TM

|Virtuoso, the V5 

Systems window will display an icon for each of the systems that are 

currently configured on the unit.  Double clicking on each of the icons will 

display a graphical representation of the selected system as shown in the 

example below. 

 

 

 

  

V5Rack System Menu  

System -> Restart system This function enables the user to send a restart request to the Access 

Network from emutel
TM

|Virtuoso. 

 

Racks -> E1 link The E1 rack will display the links that are currently configured at the Local 

Exchange.  From this rack the user can gain more information about the E1 

Link status. 

 

 

 

 A right-click on an E1 link icon displays further menu options that will now 

be described in more detail. 
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E1 link icon right-click menu options Blocking -> Immediate 

The Local Exchange will immediately block the link. 

 

 Blocking -> Unblock  

The emutel
TM

|Virtuoso Local Exchange simulator will send an Unblock 

Request to the V5 Access Network for the required E1 link. 

 

ID Request 

This message will invoke the emutel
TM

|Virtuoso to send an ID request out 

on that particular Link. 

 

Info Request 

The info request message will ask emutel
TM

|Virtuoso to return all the 

relevant port information.  This information will be displayed in the systems 

messages window after API_LINK_INFO_CO. 

 

E1 link icon pop-up information Hovering over an E1 link icon with the mouse pointer displays the relevant 

information for that link such as L3 address and timeslot information. 

 

E1 link icon LEDs and blocking information The activity and state of the E1 link is presented visually to the user.  The 

LED at the centre of the icon will turn Red when the link is active.  When the 

Link is blocked the coloured bar at the bottom of the link is Red.  When the 

Link is unblocked this will change colour to Green.  The number that is 

displayed in this bar represents the Layer3 address of the Link. 

 

Rack -> ISDN Rack BRI From this rack the user can gain more information about the Basic Rate 

Interface (BRI) ports. Each ISDN rack can display 15 BRI ports. 
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 A right-click on a BRI port icon displays further menu options that will now 

be described in more detail. 

 

BRI port right-click menu options Block Port 

This command initiates the emutel
TM

|Virtuoso to send a port block request 

to the Access Network to block that particular port.  The port will then enter 

the OUT OF SERVICE state. 

 

Unblock Port 

The Unblock Port command enables emutel
TM

|Virtuoso to request that a 

particular port be unblocked to the Access Network.  If this is successful the 

port will enter the AN1 NULL state. 

 

 Get Port Info 

The Get port Info command enables the user to gather all the information 

about that port that is currently available such as L3 address and port state. 

 

Port Status -> Activate Access 

Sends an ISDN port status FSM request to activate port access. 

 

Port Status -> De-activate Access 

Sends an ISDN port status FSM request to deactivate port access. 

 

BRI port icon pop-up information Hovering over a BRI port icon with the mouse pointer displays the relevant 

information for that port such as L3 address and telephone numbers. 

 

BRI port icon LEDs and blocking 

information 

The activity and state of the BRI port is presented visually to the user.  The 

icon has four LEDs: 

 

P LED - When the P LED is red this means that the Physical layer is active 

for this particular BRI. 

D LED - When the D LED is red this means that the D-channel for this 

particular BRI is active. 
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 B1 LED - When the B1 LED is red this means that the B1-channel for this 

particular BRI is currently in use. 

 

B2 LED - When the B2 LED is red this means that the B2-channel for this 

particular BRI is currently in use. 

 

When the BRI is blocked the coloured bar at the bottom of the link is Red.  

When the BRI is unblocked this will change colour to Green.  The number 

that is displayed in this bar represents the Layer3 address of the port. 

 

Racks -> PSTN RACK Each PSTN rack can display 30 PSTN ports.  From this rack the user can 

gain more information about the PSTN ports.  A right-click on a PSTN port 

icon displays further menu options that will now be described in more detail. 

 

 

  

PSTN port right-click menu options Block Port 

This command initiates the emutel
TM

|Virtuoso to send a port block request 

to the Access Network to block that particular port.  The port will then enter 

the OUT OF SERVICE state. 

 

 Unblock Port 

The Unblock Port command enables emutel
TM

|Virtuoso to request that a 

particular port be unblocked to the Access Network.  If this is successful the 

port will enter the AN1 NULL state. 

 

 Get Port Info 

The Get port Info command enables the user to gather all the information 

about that port that is currently available such as L3 address and port state. 

 

Hovering over the Port icon with the mouse pointer displays the relevant 

information for that PSTN port such as L3 address and telephone number. 
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PSTN port icon LEDs and blocking 

information 

The activity and state of the PSTN port is presented visually t the user.  The 

icon has four LEDs: 

 

RG LED - The Ring LED will flash red when the PSTN port at the Access 

Network is ringing. 

 

 HK LED - The Hook LED will illuminate red when the PSTN port at the 

Access Network is off hook. 

 

When the PSTN port is blocked the coloured bar at the bottom of the link is 

Red when the PSTN port is unblocked this will change colour to Green.  

The number that is displayed in this bar represents the Layer3 address of the 

port. 

 

Further information on V5Rack Please refer to the online Help file in the V5Rack program. 
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The emutel configuration file The emutel Windows application software is supplied with two files in the 

directory called v51config.v5 and v52config.v2. 

 

Changing the text files allows the configuration of the unit to be matched to 

the Access Network.  An explanation of the text file sections is given below. 

  

[SYSTEMS] Indicates to the emutel
TM

|Virtuoso that the following data contains all of the 

information for each V5 system. 

  

SYSTEM The number that follows this determines which system the following 

information belongs too. 

 

V5type The V5type determines whether a system is V5.1 or V5.2 using the numbers 

1 (V5.1) and 2 (V5.2). 

 

Variant Id The user can change the Variant Id to match the Access Network.  If the 

Variant Id does not match the AN equipment’s Variant Id the interfaces will 

fail to start up together. 

 

Interface Id The user can change the Interface Id to match the Access Network.  If the 

Variant Id does not match the AN equipment’s Interface Id the interfaces 

will fail to start up together. 

 

Ctrl_lcc_id  

pstn_lcc_id   

bcc_lcc_id    

link_lcc_id 

This number represents the Logical C-channel Id. This number is defined at 

the Link configuration and will determine the timeslot on which the Ctrl 

protocol is implemented.  Due to the restriction of V5.1 these values should 

be set to 1. 

 

 

[BRI PORTS] Informs the emutel
TM

|Virtuoso that the following information represents the 

systems Basic Rate Interfaces. 

 

BRI This text followed by a number represents the Basic Rate port number. 

 

l3_address Enables the user to set the Layer 3 address of the desired port. 
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System This enables emutel
TM

|Virtuoso to determine which system the ISDN port 

belongs to. 

 

ds_lcc_id 

(V5.2 only )  

This function enables the user to set the Logical C-channel that ISDN D-type 

( SAPI 0 calls). 

 

p_lcc_id 

(V5.2 only ) 

This function enables the user to set the Logical C-channel that ISDN P-type 

( SAPI 16 calls). 

 

f_lcc_id 

(V5.2 only ) 

This function enables the user to set the Logical C-channel that ISDN F-type 

( SAPI 32 - 62  calls). 

 

Time_slot_B1 

(V5.1 only) 

This function enables the user to allocate the timeslot value for the B1 

channel. 

 

Time_slot_B2 

(V5.1 only) 

This function enables the user to allocate the timeslot value for the B2 

channel. 

 

[PSTN PORTS] Informs emutel
TM

|Virtuoso that the following information represents the 

systems PSTN ports. 

 

PSTN This text followed by a number represents the PSTN port number. 

 

l3_address Enables the user to set the Layer 3 address of the desired port. 

 

System This enables emutel
TM

|Virtuoso to determine which system the PSTN port 

belongs to. 

 

Time_slot 

(V5.1 only) 

This function enables the user to allocate the timeslot value for the pstn port. 

 

[E1 LINKS] Informs emutel
TM

|Virtuoso that the following information represents the 

systems E1 links. 

 

LINK This text followed by a number represents the Link number. 
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System This enables emutel
TM

|Virtuoso to determine which system the E1 Link 

belongs to. 

 

 This function enables the user to set the Link to three types: 

♦ PRIMARY_LINK 

♦ SECONDARY_LINK 

♦ NORMAL_LINK 

♦ UNUSED_LINK 

 

 PRIMARY_LINK 

Primary Link identifier to the V5 system.  Each V5.2 system must have a 

Primary link defined. 

 

SECONDARY_LINK 

Secondary Link identifier to the V5 system.  Each V5.2 system must have a 

Secondary Link defined. 

 

NORMAL_LINK 

The normal link defines any active link that is not Primary or Secondary. 

 

UNUSED LINK 

An unused link defines a link that is not to be used in the new configuration. 

 

l3_address Each link must have a Layer 3 address. 

 

ts_16_type 

ts_15_type 

ts_31_type 

The timeslot (ts) type for each communication channel has three options: 

LOGICAL_TIMESLOT – This value sets the particular timeslot on that link 

to be a logical C-channel. 

  

 STANDBY_TIMESLOT - This value sets the particular timeslot on that link 

to be a standby timeslot.  Standby timeslots should only be configured on the 

secondary link. 

 

NORMAL_TIMESLOT - This value sets the particular timeslot on that link 

to be a normal Bearer Channel. 
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[BCC_ALLOC] Informs the emutel
TM

|Virtuoso that the following information represents the 

V5.2 BCC allocation method for timeslots. 

 

Bcc_alloc_method The allocation method is used to determine the method by which each 

timeslot is allocated for a V5.2 call 

 

 NORMAL_ALLOCATION 

All the Timeslots are allocated on the Primary Link first before moving to the 

secondary link and then to any other link connected.   

 

CYCLIC_LINK  

Each allocation will be done on the following link to the previous allocation.  

If Call 1 is allocated TS 1 Link 1 

Call 2 will be allocated TS 1 Link 2 

This will continue until all the Timeslots have been allocated on all of the 

Links 

 

CYCLIC_TIMESLOT 

The BCC protocol will allocate the next timeslot even if the previous 

allocation has been de-allocated. 

 

EVEN_ALLOCATION 

The BCC protocol will allocate the next Link even if the previous allocation 

has been de-allocated. Thereby spreading the traffic across all the available 

links. 

  

Note Each line must end in a semi colon else upload to the emutel
TM

|Virtuoso 

will be unsuccessful. 
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V5 Analyser menus introduction A brief introduction to the menus of V5 Analyser follows.  Comprehensive 

help on the V5 Analyser program is available in the online Help. 

 

FILE -> OPEN CAPTURE 

 

Opens a previously saved binary capture.  Previous traces saved as a binary 

file will be of type *.CAP.  The Open Capture command will default to the 

Windows Desktop directory.  Shortcut key (Ctrl + O) 

 

FILE -> SAVE AS (ASCII) The current trace will be saved as a text file  (*.txt) and can be retrieved 

using a simple text editor.  Shortcut key (Ctrl + S) 

 

FILE -> SAVE AS (Binary) The current trace will be saved as a binary file (*.CAP). This file can only be 

retrieved using the V5Analyser software. 

 

FILE -> Load Configuration Loads in a saved configuration file, which can be applied to a current trace.  

 

FILE -> Save configuration Writes the current configuration of the V5Analyser to file for future use. 

 

FILE -> Load Filter Retrieves a previously stored filter for use on a saved file, display file or the 

current history buffer. 

 

FILE -> Save filter Writes the current filter settings to file for retrieval at a later date. 

 

FILE -> Exit Exits the V5Analyser application.  Shortcut key (Ctrl + X) 

  

Monitor -> Connection Enables the V5Analyser to receive analyser messages from the emutel 

Graphical User interface.  Ensure that analyser is enabled in the emutel 

application.  Shortcut key (Ctrl + C) 

  

Monitor -> Disconnection Stops the V5Analyser buffers receiving messages in the history buffer.  

Shortcut key (Ctrl + D) 

  

Monitor -> Start Recording Begins writing incoming analyser messages file.  This function can be use 

for long periods of testing where the history buffer may not be big enough to 

hold all the required messages. 
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Monitor -> Stop Recording Prevents further incoming messages from being written to file. 

 

Monitor -> Pause Stops the current display from scrolling and continues writing analyser 

messages to the history buffer or file. 

 

Monitor -> Stop (Play & Record) Stops recording to the file and prevents further analyser messages being 

displayed. 

  

Monitor -> Clear History Buffer When beginning a new trace it is important to ensure that the history buffer 

is cleared.  This avoids confusion during analysis. 

 

Monitor -> Display Led Panel Displays the Link configuration using a graphical display panel located in a 

small window above the analyser message.  These LEDs graphically display 

the links that are to be monitored and the direction which the messages are 

being monitored. 

 

Monitor -> Display Status Bar 2 Enables the bar beneath the analyser window.  This enables you to view the 

Path and Name of the current Record file and the current configuration file. 

 

Analyzer  Displays the path of the capture file for the current Analyser trace. 

 

Search -> Find Enables the user to search the current trace for a particular string of text.  

The search window gives an option to search file in required direction (up or 

down).  The search criteria can be set to be case sensitive.  Shortcut Key 

(Ctrl + F) 

 

Search -> Next The next command enables the user to search for the required string of text 

again in the same direction as defined in the original search.  This operation 

can be used repeatedly to search the whole file.  Shortcut Key (F3) 

 

Search -> Previous The previous command enables the user to search for the required string of 

text as defined in the original search in the opposite direction to the original 

search criteria. This operation can be used repeatedly to search the whole file 

in this direction.  Shortcut Key (F2) 
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Markers -> Go to marker 1 Moves the cursor line to a predefined first marker point.  Used in large traces 

to jump to the start of a significant event.  Shortcut Key (F5) 

 

Markers -> Go to marker 2 Moves the cursor line to a predefined second marker point.  Used in large 

traces to jump to the end of a significant event.  Shortcut Key (F6) 

 

Markers -> Set marker 1 This function allows the user to mark the starting point of a trace that may be 

a significant point of interest in a large file.  The user can find this part of 

text quickly using the shortcut key F5.  Shortcut Key (Ctrl + F5) 

 

Markers -> Set Marker This function allows the user to mark the end point of a trace ending the user 

interest in the trace. The user can find this part of text quickly using the 

shortcut key F6.  Shortcut Key (Ctrl + F6 ) 

 

Tools -> triggers -> trigger action The trigger function can be used to begin a recording action to a file.  The 

triggering function allows the user to trigger on a particular event in Layer 1, 

Layer 2 and Layer 3.  The triggering action allows this function to be set up.  

Within this function the user can enable or disable triggering, define the 

action to be taken i.e. record to file.  

 

This function also enables the user to define the size of the triggering file by 

selecting the number of messages to be stored before the selected event has 

occurred and the number of messages after the selected event has occurred.  

This controls the size of a trace and enables the user to look for a certain 

event, which may occur in a bulk call test over a period of time. 
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Tools -> triggers -> Layer 1 triggering event Enables to user to define the criteria for triggering a record to file due to a 

particular Layer 1 event occurring such as loss of power or CRC error. 
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Tools -> triggers -> Layer 2 triggering event Enables to user to define the criteria for triggering a record to file due to a 

particular Layer 2 event occurring.  This includes the direction of the 

message, the protocol (BCC, PSTN, ISDN etc) and the message. 

 

 

 

Tools -> triggers -> Layer 3 triggering event Enables you to define the criteria for triggering a record to file using three 

methods: 

 

Checking for a specific message 

Checking for a specific pattern in layer 3 

Using a combination of options 1 and 2 however you must specify the 

‘Logic’ between the trap (1) and (2):  the layer 3 trigger event is verified if 

trap (1) and trap (2) are verified, or only if one of the traps is verified. 
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 1.Checking for a specific message 

 

The data to trap is defined by a specific protocol message (or ‘Any’), by a 

network direction (From -> to; AN = Access Network & LE = Local 

exchange), and by an L3 address entered in hexadecimal value (or ‘Any’). 

 

 2.Checking for a specific pattern 

 

This is especially useful when you are looking for a sequence in signalling 

data.  The data to trap is defined with a specific pattern to find in layer 3 

messages. 

 

 A pattern is a sequence of bytes.  Enter the pattern as a consecutive sequence 

of bytes (one byte per line) in the area named "Bit pattern”: each byte is 

represented by its 8 bits value (0 or 1 or “x” meta-character). Meta-character 

"x" is also allowed: "x" means any byte value in that position is fine. 
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 Also enter Position and Offset value in order to define the position where to 

find the pattern in the layer 3 protocol message: 

 

-‘Position’: choose either ‘From Start’ or ‘From End’. ‘From Start’ position 

is the first byte in the layer 3 protocol message, which is the Protocol 

discriminator. 

 

-‘Offset’: define the offset in bytes, regarding the ‘Position’ chosen. 

 

 Note: Layer 3 Address (L3Address):  It is used to uniquely reference a user port or a common 

control function.  In case of PSTN user port this shall be a 15 bit number.  In case of an ISDN 

user port or a common control function, this shall be a 13 bit number but the L3Address entered 

here is always a 16 bit number composed by the 2 bytes which come after the protocol 

discriminator byte. 

 

Note: in the ‘Bit pattern’ area, do not leave blank lines between two bytes of pattern. 
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Tools -> statistics The statistics function enables the user to view the number of occurrences of 

any message in Layer1, Layer2 and Layer3 events.  Within each window you 

can apply the statistics count to the monitor, history buffer, or between 

markers.  Analysis can also displayed as a pie chart and applied to any of the 

protocols such as PSTN, ISDN and BCC protocols running within V5. 

 

 

Tools -> Traffic Monitor The traffic monitor enables the user to view graphically the average, 

maximum and current rate at which an event is happening. 

 

 

 

 The traffic monitor has a very intuitive user interface.  Some useful tips are: 
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 Add as many charts as you want by choosing "Add an element" from the 

"Edit" menu.  For each element, the chart shows the Maximum ("Max") 

throughput, the global Average ("Av") throughput since the element has 

been added, and the current throughput ("Cur") which is an average value 

over a time interval specified by yourself in the element's properties. 

 

 To select a particular chart, just left-click it.  The information displayed in 

the status bar is relative to the selected chart i.e. the "Elapsed time" over 

which the Average value ("Av" bar) is computed, the "Time Interval" over 

which the current value ("Cur" bar) is computed, and the time when the last 

message in concern arrived. 

 

 Get the properties of a particular chart by double clicking on it.  The 

properties are: 

 

- The chart's Time Unit. 

 

- The Time Interval. The instant value (the red bar in the screenshot) is 

calculated over this time interval. 

 

 Start the Journal recording to save the values as time pass.  This will let 

you create with Microsoft Excel, for instance, a time historical chart. 

  

 Choose "File \ Exit" to close the Traffic Monitor if you DO NOT want to 

continue monitoring the traffic (as a background task).  Otherwise choose 

"File \ Hide" or click on the upper-right hand icon to close the window. 

  

Setup -> Protocol selection Protocol selection should be set to V5.1 & V5.2 protocol 

 

Setup -> configuration This function sets the V5Analyser to be configured to a source.  It has three 

functions: 
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 1. Server settings  

For use with the emutel windows application the sever settings should 

be set to local. 

2. Capture 

This function sets record file and history buffer size.  It also enables the 

user to set the buffer to wrap or stop recording when full. 

3. Source 

Source will automatically display the current C-channels that are 

available from the emutel
TM

|Virtuoso. 

  

Setup -> filters Filters can be applied to reduce the amount of information displayed to the 

user.  This can be achieved by two methods: 

 

1. Suppress/ include selected messages 

2. Suppress/include Layer3 address 

 

 The filters can be applied by selecting the active button on the filter 

window.  The filter can be applied for Layer1, Layer2 and Layer3 

messages. 

 

The filters can be applied  

- to an existing trace,  Setup ->filters->display 

- to a record file, Setup ->filters->record 

- to a history buffer, Setup ->filters->history buffer 
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 1 Message Filter 

 

Important: With the V5 protocol using ISDN port, you can have a double 

layer filter: a filter for V5 protocol messages and L3 address and another for 

ISDN messages and Call Reference value. 

 

Select the protocol messages to keep or to suppress with the help of the 

arrow buttons. 

 

 Arrow buttons 

Use the arrow buttons to move one or more message from one list to the 

other. 

- To move the entire message from one list into the other click the double 

arrow buttons (>> or <<). 

- To move only the selected message or messages from one list into the 

other, click the single arrow buttons (> or <). 
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 2. L3Address or Call Reference Filter 

 

V5 Protocol: Layer 3 Address (L3Address) 

It is used to uniquely reference a user port or a common control function.  In 

case of PSTN user port this shall be a 15 bit number.  In case of an ISDN 

user port or a common control function this shall be a 13 bit number but the 

L3Address entered here is always a 16 bit number composed by the 2 bytes, 

which come after the protocol discriminator byte. 

 

 Enter the L3Addresses in hexadecimal value and then choose if you want 

either to exclude or to include only those L3 addresses. 

 

 ISDN Protocol: Call Reference Value 

It is used to identify the call request at the local user-network interface to 

which the particular message applies.  The Call Reference value must be 

entered in decimal value. 

 

Setup -> Display modes The display modes function allows the user to set the format of the messages 

that are displayed in the window.  This enables the user to set the decoding 

for each layer: 

Layer 1 – ON\OFF or ALARM ONLY 

Layer 2 – OFF\HEX\SHORT\COMPLETE 

Layer 3 - OFF\HEX\SHORT\Identified\identified + values\COMPLETE 

 

The colours tag enable the user to change the colour combinations of 

messages.  The colours of the messages can be customized to suit the user. 

 

Setup -> save setting on exit This will save any new setting to the setup configuration on exiting the 

V5Analyser 

 

Setup ->save settings now Saves the setup changes on selection. 
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Windows -> New Enables the user to view a current display in another window.  This means 

you can have a different display method in the second window.  Both 

windows will scroll together.  This ensures that both trace decodes are at the 

same point in the current trace.  Shortcut Key (Ctrl + W) 

 

Help->Online help The online help will enable the user to obtain explanations of the functions 

shown above.  This path may need to be initially set.  When selecting the 

online help function the V5Analyser may display an error message in finding 

the help files.  From this error message select browse to find the required 

files on your computers hard disk. 

 

Help ->V5 protocol guide The V5 protocol guide help gives the user a general description of the V5 

messages defined in ETS 300 324 and ETS 300-347 
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PORT TELEPHONE NUMBER 

 

V5BRI1 320000 

V5BRI2 320010 

V5BRI3 320020 

V5BRI4 320030 

V5BRI5 320040 

V5BRI6 320050 

V5BRI7 320060 

V5BRI8 320070 

V5BRI9 320080 

V5BRI10 320090 

V5BRI11 320100 

V5BRI12 320110 

V5BRI13 320120 

V5BRI14 320130 

V5BRI15 320140 
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PORT TELEPHONE NUMBER 

 

V5PSTN1 310001 

V5PSTN2 310002 

V5PSTN3 310003 

V5PSTN4 310004 

V5PSTN5 310005 

V5PSTN6 310006 

V5PSTN7 310007 

V5PSTN8 310008 

V5PSTN9 310009 

V5PSTN10 310010 

V5PSTN11 310011 

V5PSTN12 310012 

V5PSTN13 310013 

V5PSTN14 310014 

V5PSTN15 310015 

V5PSTN16 310016 

V5PSTN17 310017 

V5PSTN18 310018 

V5PSTN19 310019 

V5PSTN20 310020 

V5PSTN21 310021 

V5PSTN22 310022 

V5PSTN23 310023 

V5PSTN24 310024 

V5PSTN25 310025 

V5PSTN26 310026 

V5PSTN27 310027 

V5PSTN28 310028 

V5PSTN29 310029 

V5PSTN30 310030 

V5PSTN31 310031 

V5PSTN32 310032 
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V5PSTN33 310033 

V5PSTN34 310034 

V5PSTN35 310035 

V5PSTN36 310036 

V5PSTN37 310037 

V5PSTN38 310038 

V5PSTN39 310039 

V5PSTN40 310040 

V5PSTN41 310041 

V5PSTN42 310042 

V5PSTN43 310043 

V5PSTN44 310044 

V5PSTN45 310045 

V5PSTN46 310046 

V5PSTN47 310047 

V5PSTN48 310048 

V5PSTN49 310049 

V5PSTN50 310050 

V5PSTN51 310051 

V5PSTN52 310052 

V5PSTN53 310053 

V5PSTN54 310054 

V5PSTN55 310055 

V5PSTN56 310056 

V5PSTN57 310057 

V5PSTN58 310058 

V5PSTN59 310059 

V5PSTN60 310060 
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PORT  TELEPHONE NUMBER 

 

V5 EMUTEL BRI1  340010 

V5 EMUTEL BRI 2 340020 

V5 EMUTEL BRI 3 340030 

V5 EMUTEL BRI 4 340040 

V5 EMUTEL BRI 5 340050 

V5 EMUTEL BRI 6 340060 

V5 EMUTEL BRI 7 340070 

V5 EMUTEL BRI 8 340080 
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ISDN interface Pin-outs The following table shows the pin-outs of the RJ45 connectors for 

the ISDN interfaces.  

 

 

 V5 ports PRI ports BRI 

E1 E1 or T1 S U 

1 T- T- NC NC 

2 T+ T+ NC NC 

3 NC NC R- NC 

4 R- R- T- RING 

5 R+ R+ T+ TIP 

6 NC NC R+ NC 

7 NC NC NC NC 

8 NC NC NC NC 

 

 


